phpstudy环境下 composer 出现 Search for a package:


phpstudy环境下 composer安装扩展时老时提示:Search for a package无法进行自动安装。这是phpstudy的bug,

修改方法:

需要看下 phpStudy\tools 里面的 composer.bat ,其中最后一个参数是 %1 ,其实是有问题的,这样会导致只能接受到一个参数,也就是当你输入 : composer require topthink/think-migration 只能接受到 require 而接受不到 topthink/think-migration , 所以才会出现 Search for a package: 。

将 %1 改成 %* 就可以接受所有的参数。